( search forums )
Soldat Forums - Soldat Talk - Need Help? Report Bugs!
November 7, 2004, 7:31 pm
Ok, i know theres alot of help out there about Dx but i can't find
a subject topic that has my problem.... and has a soulition... well heres my problem when i goto play i get setup screen, i can do all that but when i click start game all i get is a black screen, i can hear the background noise but i can't see jack all.... anybody have this problem and got it fixed???.... oh btw i'm using voodoo3... maybe thats the reason i can't play?

November 7, 2004, 7:35 pm
From the official FAQ:

6. I play the game and I don't see anything. I just hear the sounds.

Turn on the monitor.
If it still doesn't work, its a hardware compatibility error. The same as in question 1.

1. The game does not run! I get an error: cannot initialize 3d hardware, or something like that.

It's a hardware compatibility error:
- Make sure you have the latest DirectX drivers
- Try to run the game in window-mode
- Change the Windows desktop colors from 32-bit to 16-bit
- Try to change some Soldat Config settings (turn off Antialiasing, check 16-bit)
- Install the latest or different video drivers
- Try changing the windows desktop resolution and bit-rate
- Try turning down or up the graphics hardware acceleration (My Computer/Properties/Performance/Graphics)
- Try updating your motherboard drivers
- If you have Windows NT/2000 install the latest service pack

November 7, 2004, 7:40 pm
oh i got Dx 9.0c i bleave.

November 7, 2004, 7:50 pm
I use voodoo3 also with DirectX 9.0b and have no problem...

November 8, 2004, 3:16 pm
XP has problems with voodoo and suggest you to use directx 90b instead of 90c whihc gives problems to some users(w98ers). Turn off options like anti-aliasing

Deleted User
May 15, 2005, 1:11 pm
Can someone please tell exactly what they did to make Soldat run on Windows XP and a Voodoo3? There's all the topics about it on the forums, but each and every one of them contains lists of things you should do instead of a simple solution. Come on people, there must be someone on here that fixed the problem.

I wouldn't be complaining if making the steps from the lists helped, but nothing helps and it's probably just a simple compatibility glitch that could be fixed in a minute if someone tried.