( search forums )
posible bug in soldat regarding azureus
Soldat Forums - Soldat Talk - Need Help? Report Bugs!
May 15, 2005, 4:36 pm
im using a lil app for bitorrent downloading called azureus v.
which uses (requires actually) Java JRE (1.5) .
well i mentioned this becuase as long as this lil app is installed (no matter if it running or not)
than after a short while playing soldat will resolve in crashing soldat
with lots of ugly messages of this type "access violation at address XXXXXXX in modul `soldat.exe` . read of address 00000000" where XXXXXX is constantly changeing (whan ever you press ok to continue play)

i presume its azurues because prior to the installtion i didnt have any problem with soldat (and that install is the only change i did prior to the problem).
ill be happy if this will be tested and a fix will be realesed in future version.


Da cHeeSeMaN
May 16, 2005, 5:09 pm
What is azureus?... if it some type of hack its going to cause errors like that...

May 16, 2005, 7:46 pm
I suggest you uninstall azureus and see if the problem goes away, and stop using it if it does. I don't think MM is going to fix a bug that occurs because of a certain bittorrent client.

Deleted User
May 17, 2005, 8:17 am
Azereus is a bittorrent client that relies on the Java Runtime Environment (or JRE as you've said) and should not interfere with Soldat as long as it isn't running. However some bittorrent clients could possibly modify your connection environment (to say without going into technical terms) and so you may want to try what BManx2000 has said and uninstall the client and give Soldat a try.

i am ahab
May 17, 2005, 10:02 am
Well what ever your problem is it isnt universal. My friend has been using azerus for 18 months with no soldat server or client problems and he swears by it. and ive had it for a good 10 without hitches.
So this makes me think that possibly its not azerus and is possibly the whole java runtime environment. but thats a big thing to have crash soldat... so are you -sure- thats the problem? what other processes are you running if you still have probs?
if your problems persist i agree with lapis, you could try another torrent app - as most i can think of are in java i'd recommend that if you're still having probelms then switch to a non java. if still mucking up try getting rid of the jre, just to test and as long as you dont rely on it for too much.
sry laz im mucking in on your turf ;P

May 21, 2005, 4:36 pm
its possiblle that the JRE is fualting soldat .
i did try uninstalling azureus and it worked fine , that was before posting .

could be that im having a complax situation on my computer that you guys dont (i am ahab and his friend) which resualt in a error reporting .

sry i cant contribute more information , meanwhile every time i wanna play soldat i just uninstall azurures and reinstall whan i need it .

cheers .

Deleted User
May 22, 2005, 6:16 am
I get the same error messages, and I believe it happens quite random, though they don't halt the game for me. They seem to happen a lot when I use large interfaces or play on really heavy scenery maps. Also, some anti-virus and firewall apps "guard" some areas of RAM, so that may cause the issue as well.

i am ahab
May 23, 2005, 10:50 am
bummer having to uninstall and reinstall every time...
ive never had the problem you're talking about though.
as for the ram, how much is in the machine you use lapis? i play soldat on a not so hot stuff amd 1200+ with only 256 ram - and i have a firewall and antivirus running. specifically avg and norton personal firewall. and i just have my page file set to mmm 384 i think (or some multiple of 2) and i dont get such dodginess. although, as many people dont seem to understand, each pc is different...
in fact i have nvidia issues... but thats another story :L

May 26, 2005, 10:04 pm
I was downloading things on Azurus and playing soldat with low ping lots of times, and its never crashed. I have a p.o.s PC too. >.<