( search forums )
KingAdmin Server Bot [1.16] (1.3 Compatable)
Soldat Forums - Soldat Fans - Fan Apps
July 25, 2005, 7:12 am
KingAdmin Server Bot Version 1.16

Changes 1.16
Added command history for current session
Added ability to load preferred admin client if needed. Location of file must be specified in settings.
Added /client command to run preferred admin client
cheat detection logic is now customiseable and more refined
Fixed bans/probation errors that occasionally caused them to loop continuously
Added basic VB scripting
Added ability to disable server flood warnings from settings
/load command now loads VB scripts
MSN bot now compatable with msn 7.5 beta
Made bannings more resiliant to game join floodings (after a very dedicated but futile attemt by someone to crash one of my running bots)
Added /view settings command. Settings.ini file will be shown in the Requests box.
Script Creator updated to help with the construction of VB Scripts


Download Updated Files:

Download Update With MSN Bot -Requires MSN 6 or 7 to run

Download latest Script Creator (1.10)

if you have errors to do with oleaut32.dll, mswinsck.ocx, richtx32.ocx or any other files like these, go to the following link and download the file package. It should solve your problems. If it does not, use Google.


July 25, 2005, 8:12 am
Everytime it said my password is wrong when I tried to login, but I'm pretty sure my password is right. It works on other admin program, this just wont let me login.

July 25, 2005, 8:25 am
make sure you don't have caps on, that's about the only thing i can think of, because everyother server i've tested it on worked

July 25, 2005, 8:36 am
I can't make it work either. I just copy paste the password, and i can connect to the server with ARSSE, but not with your tool. And if i press "Save Log", it shuts down with some error message.

July 25, 2005, 8:37 am
There are only numbers in my password. Still not working.

July 25, 2005, 8:44 am
can you post a screenshot of what happens? this might help. It could also be a problem with the dll files, try downloading this
also try replacing your mswinsck.ocx and richtx32.ocx files. These links tell you how.

i have tried, and I am not able to replicate your problems

July 25, 2005, 9:08 am
(Uh, ignore that chinese word)
I'm not installing in the default path, it might cause the problem.

July 25, 2005, 9:13 am
maybe the settings.ini is in the wrong folder?
all files should be in the same folder as the executeable

July 25, 2005, 9:33 am
Yeah, same error message for me. All the files are in the same folder, i installed to default path.

July 25, 2005, 9:40 am
what windows version are you running?

July 25, 2005, 9:42 am
Windows XP + SP1 here...

July 25, 2005, 9:55 am
ok, i think i've found the problem. It seems to be an issue with the install program. Ill just send them all in a zip file instead.

EDIT: ok same link, try it now

July 25, 2005, 10:04 am
Ok, the log now works, but still says invalid password...

July 25, 2005, 10:08 am
make sure you don't press the connect button more than once, there is a 5 second delay on sending the pass to the server. This may be your problem.

Deleted User
July 25, 2005, 10:11 am
This problem also happens to me.

July 25, 2005, 10:17 am
ok... um, is anyone willing to give me admin for a short time on their server to try fix this problem? All the testers and I have been running this on the iinet servers, maybe tank's script has something to do with it? not sure

I know it's a big ask, but i dont see any other way. PM me would probably be the best idea

July 25, 2005, 10:19 am
just try to run a normal soldatserver on your pc (not the one shipped with soldat, but the one you can download from soldat.pl under downloads/servers)

And yes, Tank's script does some abnormal things. For example you can't use the adminchat function if you the server is not run by Tank's script.

July 25, 2005, 10:22 am
ok ill try that

EDIT: ok it does appear to be an issue with tank's script, ill try make a fix for it.

Deleted User
July 25, 2005, 10:32 am
Make sure you are doing this Kingbob..
Public Sub Sock_Connect()
Sock.SendData txtPassword.text & vbCrLf
End Sub
According to my packet logs, you arent sending a password to the server AT ALL.

July 25, 2005, 10:58 am
i was sending the pass, but tank's script acts differently to the server. Anyways i think i've fixed it now. Same link.

July 25, 2005, 7:17 pm
It's fixed now, good luck with it.

Deleted User
July 25, 2005, 9:39 pm
Very nice program and includes good in-game commands for everyone. And when run with an another admin program its awesome. As i run it with ARSSE it works well, but could u make it make so this can be minimized.

July 27, 2005, 6:28 am
Update available, it has many bug fixes, and also has the ability to minimise to the system tray. Enjoy

Deleted User
July 27, 2005, 6:36 am
uh, I dont think you can use /shutdown... that exits the Soldat client...

July 27, 2005, 6:42 am
/shutdown replaces the Shutdown button on the admin client. Test it, it works. Some people might use it, I have from time to time to reset the iinet servers

July 27, 2005, 1:02 pm
do something about select-bug.

(try to select the text in the console and wait for any new line, eg. REFRESH)

Oh, and the black text is hardly readable on that background..

Some other bugs:
-Do something with the message box. It has no scrollbars, and inserts new messages to the current caret position, not to the end.
-The sounds are too low.
-ingame commands !about and !test don't work (at least i couldn't make them work..)

July 27, 2005, 2:44 pm
ok, those should be easy enough to fix. Ill try boost the sound on the files, but if this doesnt work there's always the volume button ;). Either that or you could change them with sounds of your own liking. !about and !test do work, you probably did them too close together. I forgot to mention that there is a 10 second flood interval on commonly used server requests such as those.

EDIT: With the chat problem, the bot is unable to tell other admins when an admin is needed. To try compensate for this, I'm going to integrate a basic MSN chat bot into the program that will tell all online admins that one is required.

July 28, 2005, 1:20 pm
Well, good that you added msn bot, but now it won't start :S
the main window won't show or something.

July 28, 2005, 1:45 pm
ok, do you people read the missing file errors that occur when these thigs start? As i have VB on my comp, these don't show for me. So please tell me if a dll or ocx file is said to be mising and i can send you a link for the file.
as for your problem, i believe this should fix it

July 28, 2005, 2:30 pm
no errors, it just won't start. the library files are installed.

July 28, 2005, 10:32 pm
that's very strange... I can run it on both my comps with no issues. Try downloading everything again. Is anyone else having this problem? HAve you got msn 6 running and are you signed in?

July 28, 2005, 10:56 pm
no, i have msn 7 running.

July 29, 2005, 12:06 am
I said in the main post that it will most likely not run with msn 7 Beta, best to use msn 6. 7 has too many bugs still anyway

July 29, 2005, 12:33 am
msn 7 is NOT beta already. there was an official release
there is a 7.5 beta tho.. however, sorry, but i won't uninstall msn 7 and re-install msn 6 for only this app, as closing msn doesn't solve the problem (of not starting the app you know)

July 29, 2005, 12:41 am
does the bot-free version have the same problem?

July 29, 2005, 12:46 am
Yes, it does :S so there must be another problem

July 29, 2005, 12:56 am
hmm... ok then, i've made a few changes to the bot-free update, try it now. It should work this time... (I hope)

And i have discovered that it does work with msn 7, so it's not that.

July 29, 2005, 1:03 am
Ok, now the msn-free version works, but the msn-bot still doesn't load.

July 29, 2005, 1:08 am
no idea about the bot version, I've tested it on 5 different computers myself and haven't been able to replicate the problem. So i suppose until I can figure this out you'll have to run the bot-free version

Ok download the bot update again and try it with windows messenger. If it works. then it is an issue with your version of msn 7.

EDIT: New version available, it can run basic scripts, and a script writing program is included with it.

EDIT2: version 1.16 out, with new features and bug fixes.

Deleted User
December 12, 2005, 9:14 am
Links OFF.

Deleted User
December 13, 2005, 3:28 am
broken links man

December 13, 2005, 4:12 pm
Can you fix links please?

Deleted User
December 30, 2005, 8:53 pm
Download link oFF!!!