( search forums )
Dedicated Server 2.3.7
Soldat Forums - Server Talk - Server discussion
Michal Marcinkowski
September 12, 2005, 4:50 pm
This is a quick fix for the map downloading problem. I replaced the old code so it should work like in Soldat 1.2.1.

Download: http://www.soldat.pl/downloads/soldatserver237.zip
Download 2.3.6 patch: http://www.soldat.pl/downloads/soldatpatch237.zip

Deleted User
September 12, 2005, 5:06 pm
Awesome, map downloads appear to be working abit better *so far*

Still no private /say function? DAMN IT!

EDIT: I just tried whoring my server with 30 TCP File server connections, 2.3.6 used to just block all connections after that, now they appear to remain open and functional ^_^ good work.

Deleted User
September 12, 2005, 5:09 pm
Thanks a lot for this fix :D
Ther are several good mappers and now we can see what they've done.

September 12, 2005, 5:44 pm

I am still having the problem.

Linux Fedora Core 1
CentOS 4.1

Both having problems. If I start my servers with the /loadlist command the servers will not start using the mapslist.txt. If I do not use that command it will start right. Now, does the command have to be used in order for the downloads to work right? It is a guess but I am just wondering?

Deleted User
September 13, 2005, 12:49 am
I'm on Windows, but I simply replaced exec, enabled downloads and it works like charm. No params used, it simply loads mapslist.txt by auto.

September 13, 2005, 6:11 am
Works for me also. Linux server, thanks MM :)

September 13, 2005, 1:14 pm
i've been using this for about 2 weeks and it hasn't seemed to cause any issues

Deleted User
September 13, 2005, 1:26 pm
sif boast...

Deleted User
September 13, 2005, 5:15 pm
Today I got this 2 times:
Error: Could not load map (Too many files open)

CTF server on Windows, allowed map download, a few "custom" maps on server. After that info appeared - server crash: no flags, guys appear with parachutes and stuff, after I used /nextmap command, same situation, I had to restart server.

September 14, 2005, 1:41 am
are you sure that the map(s) it tried to load are actually in the maps folder, not misspelled in mapslist.txt or anything? I remember getting this error, and that was the issue with me

Deleted User
September 14, 2005, 3:20 am
Ven0m, http://archive.forums.soldat.pl/topic.php?topic_id=26137

September 14, 2005, 12:14 pm
Cool! Before my friends would get a lot more map errors (wrong versions, or random crashes) but downloads work fine now...Thx! :D

September 15, 2005, 3:29 am
For some reason i cant addbots with the soldat admin program, even when i set the soldat.ini to use some bots... it doesnt work. Anyone else have this problem... and yes I'm spelling '/addbot billy' right;)

[Edit] And just because I just noticed it, love the php script for the avatar Enesce [/Edit]

Deleted User
September 15, 2005, 4:00 am
@Rapterion, bot names are case sensitive. if your in ctf, you need to do /addbot2 Billy (2 for bravo, 1 for alpha)

September 15, 2005, 4:16 am
Thanks enesce, I was in CTF, I had tried all cases, but i didnt know about addbot1 and addbot2.

Deleted User
September 15, 2005, 6:34 am
Thank you. *D/L's*

Deleted User
September 15, 2005, 9:17 am
EnEsCe, thanks for reply, but maplist looped several times. No idea what was the fault. After these 2 "accidents", server hadn't got any problems.

September 15, 2005, 9:28 am
Good work, upgraded all my servers, and everything seems to be working good so far.
EDIT. And thanks for adding the /loadlist command. :D

September 15, 2005, 2:48 pm
i'll be upgrading the rest of mine when i'm between classes later

October 1, 2005, 6:10 pm
This is perfect MM, been running the server for a few days now, no random shutdowns from using custom maps!! I'm running windows in case you wondered, but great job MM!

October 1, 2005, 8:04 pm
yeah i've been running this for a couple weeks now and it hasn't crashed at all, custom maps or otherwise.

yay stable servers!