( search forums )
Never mind, DX works now (for some reason)
Soldat Forums - Soldat Talk - 1.3.1 related complaints and/or whining -NO BUGS-
Keron Cyst
December 11, 2005, 4:24 pm
I played on a server, which crashed, and I was done for that time. Then I tried to play Soldat an hour or so later and now it says (yes, I'm typing now in present-tense instead of past; I still have the error) I need at least DirectX 8.0 when dxdiag says I have 9.0c. I ran the D3D test in dxdiag and it failed all three when they normally succeed.

[code] D3D7 Test Result: Failure at step 37 (SetCooperativeLevel to Fullscreen): HRESULT = 0x88760245 (error code)
D3D8 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x88760868 (error code)
D3D9 Test Result: Failure at step 8 (Creating 3D Device): HRESULT = 0x88760868 (error code)[/code]

I'm quite positive Soldat caused the defection; I didn't touch anything else during that time.

I got the setup from Microsoft.com and it didn't even reinstall; I just accepted the license agreement to install and it instantly said "Installation Complete" without even opening any files. the_ven0m from #soldat.polyworks knows. He said to troubleshoot by right-clicking the desktop, going to Properties, and going to the Troubleshoot secion of the Settings tab, but that has no straight-away area for inquiring about DirectX.

I'm not even gonna touch this version of the game anymore until a bugfix is released. Now I can't even work on waypoints because MM+ (and I'm sure PW, even tho' I haven't tried it yet) requires DX as well, so for now I'm gonna have to resort to my ME and it's 1.3 for wypt.-testing. In the meantime, can anyone help me out? MANY thanks in adv.

Ugh... ¦-|

It works. The tests are all passing successfully. I don't know why. I will never play 1.3.1 without the next bugfix online again.

December 11, 2005, 4:27 pm
Oh damn... you scared me there. Hope this wont happen in my comp..

December 11, 2005, 4:36 pm
did you try uninstalling directx, restarting your computer, and reinstalling it?

Keron Cyst
December 11, 2005, 4:40 pm
How on earth can you uninstall DX? I thought that was necessary to Windows (or somethin' like that). the_ven0m said there were non-Microsoft uninstallers, but I'm not sure how to go about finding them (just Google?...).

December 11, 2005, 5:32 pm
don't use it unless you're sure your computer won't explode if you take DX away.

December 11, 2005, 5:37 pm
sorry, i replied to this thread about 30 seconds after i woke up. I meant to ask if you just tried reinstalling directx over the current installation.

Keron Cyst
December 12, 2005, 1:32 am
Yeah, that's what I did.

quote:Originally posted by n00bface
... don't use it unless you're sure your computer won't explode if you take DX away.
How can I be sure?... oO'

Yay. Read above. No clue. All I did was try to run the DX setup a few times, and upon that, gave up and restarted the comp. Then I came back after church ~7 hours later and everything pwns. I guess you can lock/delete this thread now...