( search forums )
Menu GUI problem
Soldat Forums - Soldat Talk - Need Help? Report Bugs!
August 29, 2003, 9:43 pm
I just reinstalled Soldat - unless the lobby server's been down for a couple of days and I didn't hear about it, I've been unable to browse other servers (although people have still joined games I've hosted - and the reinstall doesn't work.

I configured all my old settings, installed the fix, all that. The menu GUI is completely screwed up. There's no text displayed and the command buttons and little boxes are all the wrong sizes, some stretching off the bottom of the screen. However, I was able to start a game, and it seemed to work just like normal for the few seconds I played - none of the text problems from the menu. Anyone know what's going on?

And sorry if this is something that's been talked about a thousand times before, but I can't search for some reason - the page won't load.

August 30, 2003, 6:15 am
The lobby has been down for a while now.

The GUI shouldn't be screwed up though.

I know of 1 or 2 other people that have had a similar problem...

What system are you running on?

DirectX version?

Video drivers?

Tried reinstalling Soldat?

Played around with settings (Soldat Setup - config.exe)?

Any weird programs running in the background?

Possibility of a virus?
Do you have anti-virus software?

August 30, 2003, 9:00 pm
Sorry, forgot the standard stuff...

P4 1.8 GHz, 512 MB RAM, GF3 TI500, DirectX and drivers completely up-to-date, reinstalled at least three times, tried messing with settings, no weird programs running that I know of, no viruses (I don't think) and NortonAV (which I never turn off, even while playing games).

The weird thing about this problem is that I uninstalled the game (which still worked fine at that time, except for the lobby), had it reinstalled (in a different directory) and reconfigured within 10 minutes, and it suddenly had all those problems. Reinstalled again, same problems. And again. Absolutely no changes were made to the system between the the uninstall and the reinstall.

August 31, 2003, 3:26 am
Oh, I think I know what the problem is...

Soldat uses a particular font, called 'bgothl.ttf'.

When you install Soldat, it will register this font with your system.

When you run Soldat, it will look for the font, and in your case, it won't find it!

So just to test this theory out...

Create a Soldat folder exactly where you had it before you moved it. And stick the font file in there.

Then post back when you're done...

September 2, 2003, 3:28 am
Fix0red! ... thanks, I should've thought of that.

September 2, 2003, 5:20 am
np, glad to be of service ;)