( search forums )
Error initializing 3D hardware?
Soldat Forums - Soldat Talk - Need Help? Report Bugs!
August 30, 2003, 3:51 am
Whenever I try to start up Soldat, I get an error message. I do get to see the little registration screen, but as soon as I click ok, I get this error:

Error initializing 3D hardware. Your hardware does not support DirectX 8. Be sure to install the latest video drivers. Now software will be used...

I click ok, then I get THIS error message:

Could not initialize DirectX Graphics. You must have DirectX 8 or better. Try turning off extra options like Antialiasing.

The thing is, I just installed DirectX 9! Is that screwing me up? I want to play soldat![:-weepn]

August 30, 2003, 6:12 am
Do you have DirectX 9.0b?

Do you have up to date versions of your video drivers?
nVidia drivers can be located here
ATI drivers can be located here

Try playing around with your settings a little (Soldat Steup - config.exe)

What system are you running on (win9x, winXP, etc.)?

August 30, 2003, 7:59 pm
I have a video card -> SiS 530. I canĀ“t run Soldat. Sometimes I receive this error message -> Couldnt load texture xxx.BMP

Sometimes the game run, but there is no image, only a black screen. Can anyone help me?

August 30, 2003, 8:55 pm
I also get this error message on a Intel 810i Graphics chip :-/ I've tried updating DirectX and my video drivers but it still gives the same error!

BHedL : To play just click video compatability in the config.

August 30, 2003, 11:28 pm
Is is possible that DirectX is screwing stuff up? I mean, I SWEAR i just installed it, and now soldat wont work, and I cant get this other thing to work either.... Man, I'll install it again I guess...

[edit: Yeah, that didn't do anything. I only have like a random 8 Mb graphics card anyway, and before I was playing soldat with barely any of those options turned on... [:(!]]

[edit number two: Oh yeah, by the way, I'm running Windows 2000 Professional.]

August 31, 2003, 3:32 am
First of all - ghtlugyt and IRRiTANT.

You really should buy a cheap video card to solve this problem...

Providing your mothermoard has an AGP slot you can buy a nVidia GeForce MX (GF 2 or 4) for such a small price, and it would solve your problems.

Soldat can't run in software mode, the option just results in a black screen of nothingness.

BHedL - What video card do you have?

August 31, 2003, 5:37 am
I think its the same thing that irritant has... heh.

[edit: But it worked before just fine!]

[edit two: Yeah, you were right. Updating driver things is all that it took to fix. Thanks for the help. I still blame directX 9 for this lapse in soldat!]

September 1, 2003, 12:18 pm
Good to hear :)