( search forums )
'integer value'... or in short- soldat doesnt work
Soldat Forums - Soldat Talk - Need Help? Report Bugs!
September 25, 2003, 11:18 pm

evrytime i'm starting soldat, it gives me that problem. i cant join a game (though i can request from lobby), i cant host a game (gives me the integer value popup), and.. well, i feel kinda lost.

my hardware:
pentium4 1700 mhz graphic card - nvidia riva tnt2, with latest updates directx 9.0 (or 9.1, forgot)

soldat has been working for me withount one prob (well, if you dont count the 'requesting' bug) for like, 7 months. doctor, help me!

the bug happend out of no where, didnt installed anything, didnt removed anything, didnt changed anything.

September 26, 2003, 12:15 am
are you sure you didnt change anything at all, no skin changer? no editing of the .ini at all?

September 26, 2003, 12:43 am
hmmmm almost looks like one of the many profile bugs...

Can you try to reinstall it?

September 26, 2003, 11:33 am
I had that error msg when i installed an old version and the newest in the same directory (like /folder/soldat and /folder/soldat105)

September 26, 2003, 2:39 pm
Me And My Friends had a LAN for 3 weeks ago.. When 1 of them Installed They Got same Problem !! Reinstalled many Times.. But Still Same error ! Soldat 1.05b Worked tho..

September 26, 2003, 4:38 pm
reinstalled it again, still doesnt work ;(

btw, i got firewall, but i doubt if thats the reason why its not working.

ooh almost forgot.
if i click 'ok' on the popup, i'm still on soldat, i mean i can go to 'player', 'options' etc.
it just gives me the popup only when i'm pressing on 'start game' or 'join game'.

TSP G-Unit
September 26, 2003, 5:07 pm
it hapenned to me, somebody told me how to fix it and it worked

September 27, 2003, 4:39 am
Well, try this:

1. Uninstall soldat
2. Install soldat 1.1.5 + fix
3. Delete the file cmodule.dll in the 'windows\system32' folder
4. Delete the file dxlog.chk in the 'windows' folder

September 27, 2003, 6:15 am
hmm seems like the problem was either reset, or the 'key chain' that can connect to your computer and work like a floopy disk, only with 16/50/etc mega.

woohoo now its working, ty all for the help.

September 28, 2003, 11:51 am
USB drive.

And that shouldn't make any difference lol - unless you were running Soldat from that... haha...

Either way :) good.